Mabuhay

Hello world! This is it. I've always wanted to blog. I don't want no fame but just to let myself heard. No! Just to express myself. So, I don't really care if someone believes in what I'm going to write here nor if ever someone gets interested reading it. My blogs may be a novel-like, a one-liner, it doesn't matter. Still, I'm willing to listen to your views, as long as it justifies mine... Well, enjoy your stay, and I hope you'll learn something new because I just did and sharing it with you.. Welcome!

Sunday, March 29, 2009

Solaris Cheat Sheet: Episode 1

Yellow everyone! Guess who's back?!? Who?? No one..

It's been a very long time since that day [whatever it is]. I've been busy lately [honestly, I'm tired blogging] so why not drop by and post something that's already there. As always, these are for my reference. You can take whatever you could and encouraged to share some. By the way, I just finished reading Hajime No Ippo and looking forward for Takamura-san's fight. As you know, Ichiro-kun just won his OPBF title defense against Randy Boy Jr. [Philippines; and it's a lame name - sorry!]. But the question is, will Ippo vs. Ichiro really materialize? Can't wait either.

Ooops.. got carried away but after reading the above, I came across a good, known site that can really help me. So here it is the first installment of my Solaris cheat sheet! [My other script is on it's way - some refinement, always, and suggestions from my colleagues -.. if you're interested, keep an eye on it ;)]

Debugging
18. cat -v -t -e [file]
/* Show non-printing characters */
19.
dumpadm -d swap
/* Configure swap device as dump device */
20.
ld -l

/* Check if you have a particular library */
21.
truss -f -p

/* Using multiple windows, this can be used to trace setuid/setgid programs */
22.
truss executable
/* Trace doing of given command ( useful debugging ) */


Disk Commands
23. /bin/mount -F hsfs -o ro /dev/sr0 /cdrom
/* Mount an ISO 9660 CDROM */
24.
/usr/bin/iostat -E
/* Command to display drives statistics */
25.
du -ad /var | sort -nr
/* Report the the disk used in /var in reverse order */
26.
du -k .
/* Report disk usage in Kilobytes */
27.
du -sk * | sort -nr | head
/* Shows the top ten largest files/directories */
28.
du -sk *|sort -k1,1n
/* Reports total disk space used in Kilobytes in present directory */
29.
du -sk .
/* Report total disk usage in Kilobytes */
30.
fdformat -d -U
/* Format diskette */
31.
mount -F hsfs -o ro `lofiadm -a /export/temp/software.iso` /mnt
/* Mount an ISO Image */
32.
newfs -Nv /dev/rdsk/c0t0d0s1
/* To view the superfblocks available */
33.
prtvtoc /dev/dsk/c1t2d0s2 | fmthard -s - /dev/rdsk/c1t3d0s2
/* One-liner to copy a partition table */
34.
prtvtoc /dev/rdsk/c0t0d0s2
/* Disk geometry and partitioning info */
35.
prtvtoc /dev/rdsk/c0t0d0s2 | fmthard -s - /dev/rdsk/c0t1d0s2
/* Copy partition table from one disk to another */
36.
quot -af
/* How much space is used by users in kilobytes */
37.
volrmmount -i floppy
/* Mount a floppy or other media easily by its nickname. */



Driver Parameters
38. ndd /dev/ip ip_forwarding
/* Show the ip_forwarding variable in the kernel */
39.
ndd /dev/ip ip_forwarding 1
/* Set the ip_forwarding variable in the kernel */
40.
ndd /dev/ip \?
/* Show all IP variables set in the kernel */



File Manipulation
41. dos2unix | -ascii

/* Converts DOS file formats to Unix */
42.
fold -w 180
/* To break lines to have maximum char */
43.
split [-linecount] [file]
/* Split files into pieces */
44.
[vi] : %s/existing/new/g
/* Search and Replace text in vi */
45.
[vi] :set list
/* Show non-printing characters in vi */
46.
[vi] :set nu
/* Set line numbers in vi */
47.
[vi] :set ts=[num]
/* Set tab stops in vi */



File System
48. /sbin/uadmin x x
/* Syncs file systems and reboots systems fast */
49.
awk ' END {print NR}' file_name
/* Display the Number of lines in a file */
50.
cat /dev/null > filename
/* Zero's out the file without breaking pipe */
51.
cksum [filename]
/* View the checksum value for the given file */
52. dd if=/dev/rdsk/... of=/dev/rdsk/... bs=4096
/* Make a mirror image of your boot disk */
53.
df -k | grep dg| awk '{print $6}' |xargs -n 1 umount
/* Unmount all file systems in disk group dg */
54.
fsck -F ufs -o b=97472 /dev/rdsk/c0t0d0s0
/* Check and repair a UFS filesystem on c0t0d0s0, using an alternate superblock */
55.
fsck -F ufs -y /dev/rdsk/c0t0d0s0
/* Check a UFS filesystem on c0t0d0s0, repair any problems without prompting. */
56.
fsck -F ufs /dev/rdsk/c0t0d0s0
/* Check a UFS filesystem on c0t0d0s0 */
57.
gzip -d -c tarball.tgz | (cd /[dir];tar xf - ) &
/* Unpacking tarballs to diff location */
58.
gzip -dc file1.tar.gz | tar xf -
/* Unpack .tar.gz files in place */
59.
ln [-fhns]

/* Creating hard links and soft links */
60.
ls -al | awk '$3 == "oracle" || $3 == "root" {print $9}'
/* List all file names by testing owner */
61.
ls -l | sort +4n
/* List files by size */
62.
ls -la | awk '{ print $5," ",$9 }' | sort -rn
/* File sizes of current directory */
63.
ls -lR | awk '{total +=$5};END {print "Total size: " total/1024/1024 "MB" }'
/* Recursive directory size calculations in MB */
64.
mkisofs -l -L -r -o [image-name].iso [directory]
/* Create an ISO image of a directory */
65.
mount -F ufs -o rw,remount /
/* Used to remount root to make it writeable */
66.
mount -o remount,logging /spare
/* Re-mount the ro file system rw and turn on ufs logging */
67.
mount -f pcfs /dev/dsk/c0d0p1 /export/dos
/* DOS fdisk partition from Solaris */
68.
mv [filename]{,.new_suffix}
/* Renaming file */
69.
pax -rw . /newdir
/* Efficient alternative for copying directories */
70.
prtvtoc /dev/rdsk/c0t0d0s2 | fmthard -s - /dev/rdsk/c0t1d0s2
/* Cloning Partitiontables */
71.
rpm -q --queryformat '%{INSTALLPREFIX}\n' [packagename]
/* [Linux] Locate binaries */
72.
tar cf - . | (cd /newdir ; tar xf -)
/* Recursively copy files and their permissions */
73.
tar cvf filename.tar
/* Create a tape (tar) archive */
74.
tar xvf filename.tar
/* Extract a tape (tar) archive */
75. X=$(wc -l < filename); echo $X
/* Count number of lines in a file into a variable (ksh) */
76. zcat < patch_file.tar.Z) | tar xvf -
/* Extracts the patch_file that is a compressed tar file */
77. zcat [cpio file] | cpio -itmv
/* Show the contents of a compressed cpio */


File Transfer
78. find . -depth | cpio -pdmv /path/tobe/copied/to
/* Fast alternative to cp -pr */
79.
find . -follow | cpio -pdumL /path/tobe/copied/to
/* Copy with symbolic links to be followed */
80.
get filename.suffix |"tar xf -"
/* Undocumented Feature of FTP */
81.
ssh cd /some/directory \&\& tar cf - | ssh cd /some/direstory \&\& tar xvf -
/* Move any file(s) without actually touching them */
82.
put "| tar cf - ." filename.tar
/* Undocumented Feature of FTP */
83.
sendport
/* FTP command for transferring large numbers of files within the same control session */


General
84. /bin/printf '%d\n' '0x'
/* Converts hexadecimal number to decimal. */
85.
/usr/bin/catman -w
/* Create windex databases for man page directories */
86.
echo 'obase=16;255' | bc
/* Simple way to convert decimal to hex */
87.
FQ_FILENAME=
; echo ${FQ_FILENAME%/*}
/* Extract directory from fully-qualifi
ed file name. */
88.
mailx -H -u

/* List out mail headers for specified user */
89.
ps -ef | grep -i $@
/* Access common commands quicker */
90.
set filec
/* Set file-completion for csh */
91.
uuencode [filename] [filename] | mailx -s "Subject" [user to mail]
/* Send files as attachments */
92.
xauth -f /home/${LOGNAME} extract - ${DISPLAY} | xauth merge -
/* Allow root to xdisplay after su */



Hardware
93. cfgadm
/* Verify reconfigurable hardware resources */
94.
m64config -depth 8|24
/* Sets the screen depth of your M64 graphics accelerator */
95.
m64config -prconf
/* Print M64 hardware configuration */
96.
m64config -res 'video_mode'
/* Change the resolution of your M64 graphics accelerator */
97.
prtpicl -v | grep sync-speed
/* Discover SCSI sync speed */



Kernel
98. /usr/sbin/modinfo
/* Display kernel module information */
99.
/usr/sbin/modload

/* Load a kernel module */
100.
/usr/sbin/modunload -i

/* Unload a kernel module */
101.
/usr/sbin/sysdef
/* Show system kernal tunable details */
102.
nm -x /dev/ksyms | grep OBJ | more
/* Tuneable kernel parameters */
103.
update_drv -f [driver name]
/* Force a driver to reread it's .conf file without reloading the driver */


Memory
104. pagesize -a
/* Available page sizes for Solaris 9 */
105.
prtconf | grep Mem
/* Display Memory Size of the local machine. */



Network Information
106. arp -a
/* Ethernet address arp table */
107.
arp -d myhost
/* Delete an ethernet address arp table entry */
108.
lsof
-iTCP@10.20.2.9
/* Display open files for internet address */
109.
named-xfer -z qantas.com.au -f /tmp/allip
/* Get All IP Addresses On A DNS Server */
110.
ndd /dev/arp arp_cache_report
/* Prints ARP table in cache with IP and MAC address */
111.
netstat -a | grep EST | wc -l
/* Displays number active established connections to the localhost */
112.
netstat -a | more
/* Show the state of all the sockets on a machine */
113.
netstat -i
/* Show the state of the interfaces used for TCP/IP traffice */
114.
netstat -k hme0
/* Undocumented netstat command */
115.
netstat -np
/* Similar to arp -a without name resolution */
116.
netstat -r
/* Show the state of the network routing table for TCP/IP traffic */
117.
netstat -rn
/* Displays routing information but bypasses hostname lookup. */
118.
snoop -S -ta [machine]
/* Snoop for network packets and get size and time stamp entries. */
119.
traceroute

/* Follow the route to the ipaddress */



Network Tuning
120. /sbin/ifconfig hme0:1 inet 10.210.xx.xxx netmask 255.255.0.0 broadcast 10.210.xxx.xxx
/* Virtual Interfaces */
121. /sbin/ifconfig hme0:1 up
/* Bring virtual interface up */
122.
/usr/sbin/ndd -set /dev/hme adv_100fdx_cap 1
/* Nailling to 100Mbps */
123.
ifconfig eth0 10.1.1.1 netmask 255.255.255.255
/* Add an Interface */
124.
ifconfig eth0 mtu 1500
/* Change MTU of interface */
125.
ndd -set /dev/ip ip_addrs_per_if 1-8192
/* To set more than 256 virtual ip addresses. */
126.
ndd -set /dev/tcp tcp_recv_hiwat 65535
/* Increase TCP-receivebuffers on Sol2.5.1 systems with 100BaseTx */
127.
ndd -set /dev/tcp tcp_xmit_hiwat 65535
/* Increase TCP-transmitbuffers on Sol2.5.1 systems with 100BaseTx */


Processes
128. /usr/proc/bin/ptree

/* Print the parent/child process 'tree' of a process */
129.
/usr/proc/bin/pwdx

/* Print the working directory of a process */
130.
/usr/ucb/ps -aux | more
/* Displays CPU % usage for each process in ascending order */
131.
/usr/ucb/ps -auxww | grep

/* Gives the full listing of the process (long listing) */
132.
coreadm -i core.%f.%p
/* Append program name and process id to core file names */
133.
fuser -uc /var
/* Processes that are running from /var */
134.
ipcs
/* Report inter-process communication facilities status */
135.
kill -HUP `ps -ef | grep [p]roccess | awk '{print $2}'`
/* HUP any related process in one step */
136.
lsof -i TCP:25
/* Mapping port with process */
137.
pfiles

/* Shows processes' current open files */
138.
pkill -n

/* Kill a process by name */
139.
prstat -a
/* An alternative for top command */
140.
ps -edf -o pcpu,pid,user,args
/* Nicely formatted 'ps' */
141.
ps -ef | grep -i
| awk '{ print $2 }'
/* Creates list of running PID by
*/
142.
ps -ef | grep -i
| awk '{ print $2 }'
/* Creates list of running PID by */
143.
ps -ef | grep
| grep -v grep | cut -c 10-15 | xargs kill -9
/* Find and kill all instances of a given process */
144.
ps -ef | more
/* Show all processes running */
145.
ps -ef|grep -v "0:00"|more
/* Gives you a list of any process with CPU time more than 0:00 */
146.
ps -eo pid,args
/* List processes in simplified format */
147.
ps -fu oracle|grep pmon
/* See which instances of Oracle are running */
148.
top -b 1
/* Returns the process utilizing the most cpu and quits */


Resource Management
149. /usr/bin/ldd [filename]
/* List the dynamic dependencies of executable files */
150.
/usr/proc/bin/pmap pid
/* Report address space map a process occupies */



Route Configuration
151. route add net 128.50.0.0 128.50.1.6 1
/* Add a route to the routing table */
152.
route change 128.50.0.0 128.50.1.5
/* Changes the destination address for a route */
153.
route delete net 128.50.0.0 128.50.1.6
/* Delete a route from the routing table */
154.
route flush
/* Flush the routing table, which will remove all entries */
155.
route get [hostname]
/* Which interface will be used to contact hostname */
156.
route monitor
/* Monitor routing table lookup misses and changes */


Searching Items
157. cat
| awk '{if (substr($1,1,1) == '#') print $0 }'
/* Print all lines in a file beginning with a specific character */
158.
egrep "patterna|patternb"

/* Search for multiple patterns within the same file */
159.
find
-name "" -exec rm -rf {} \;
/* Recursively finds files by name and automatically removes them */
160.
find . -type f -print | xargs grep -i [PATTERN]
/* Recursive grep on files */
161.
find . ! -mtime -
| /usr/bin/xargs rm -rf
/* Finds and removes files older than
specified */
162.
find . -exec egrep -li "str" {} \;
/* Find a string in files starting cwd */
163.
find . -mtime -1 -type f
/* Find recently modified files */
164.
find . -type f -exec grep "
" {} \; -print
/* Find files (and content) containing
within directory tree */
165.
find . -type f -exec grep -l "
" {} \;
/* Find files (and content) containing
within directory tree */
166.
find ./ \! -type f -exec ls -l {} \;|grep -v '^[l|p|s|-]'|grep -v 'total' | wc -l
/* Find number of directories under the current directory */
167.
find / -fstype nfs -prune -o fstype autofs -prune -o -name filename -print
/* Find without traversing NFS mounted file systems */
168.
find / -mtime <# of days>
/* Find files modified during the past # of days */
169.
find / -perm -2 -a ! -type l
/* Find files writable by 'others' */
170.
find / -type f |xargs ls -s | sort -rn |more
/* List files taking up the most system space */
171.
find / -user

/* Find all files owned by
*/
172.
find / -xdev -type f -ls|sort -nr -k 7,7
/* Find largest files in a file system */
173.
find / | grep [file mask]
/* Fast way to search for files */
174.
find /proc/*/fd -links 0 -type f -size +2000 -ls
/* Find large files moved or deleted and held open by a process */
175.
grep
/var/sadm/install/contents| awk '{ print $1 ' ' $10 }'
/* Find which package contains a particular file */
176.
ls -lR | grep

/* Fast alternative to find. */
177.
pkgchk -l -p /absolute/path/todir
/* Which package does this file belong to? */



Security
178. crypt
abc && rm abc.cr
/* Decrypting a file that has been encrypted */
179.
crypt
abc.cr && rm abc
/* File encryption with crypt */
180.
echo 'Please go away' > /etc/nologin
/* Stops users logging in */
181.
find / -perm -0777 -type d -ls
/* Find all your writable directories */
182.
find / -type f -perm -2000 -print
/* Find all SGID files */
183.
find / -type f -perm -4000 -print
/* find all SUID files */
184.
getpwenc [encryption scheme] password
/* Genrate passwords for LDAP Using 'getpwenc' Utility */
185.
trap 'exit 0' 1 2 3 9 15
/* Trap specific signals and exit */
186.
vi -x [filename]
/* Encrypt a file with vi editor */



Setting Term Options
187. stty erase ^?
/* Set the delete key to delete a character */
188.
stty erase ^H
/* Set the backspace to delete a character */
189.
stty sane
/* Reset terminal after viewing a binary file. */
190.
tput rmacs
/* Reset to standard char set */



Snoop
191. snoop -d pcelx0
/* Watch all the packets on a device */
192.
snoop -i /tmp/mylog -o /tmp/newlog host1
/* Filter out all the host1 packets and write them to a new logfile */
193.
snoop -i /tmp/mylog -v -p101
/* Show verbose info on packet number 101 in the logfile */
194.
snoop -i /tmp/mylog host1 host2
/* View packets from a logfile between hosts1 and host2 */
195.
snoop -o /tmp/mylog pcelx0
/* Save all the packets from a device to a logfile */
196.
snoop -s 120
/* Return the first 120 bytes in the packet header */
197.
snoop -v arp
/* Capture arp broadcasts on your network */
198.
snoop port [port-number]
/* Monitor particular port for traffic */


Swap Files
199. mkfile -nv 10m /export/disk1/myswap
/* Makes an empty 10 Megabyte swapfile in /export/disk */
200.
mkfile -v 10m /export/disk1/myswap
/* Makes a 10 Megabyte swapfile in /export/disk */



Swap Space
201. swap -a /export/disk1/swapfile
/* Add a swap file */
202.
swap -d /dev/dsk/c0t0d0s4
/* Delete a swap device */
203.
swap -l
/* List the current swap devices */
204.
swap -s
/* List the amount of swap space available */



System Configuration
205. /usr/sbin/eeprom auto-boot? false
/* Changes eeprom autoboot? setting without going to Ok prompt */
206.
/usr/sbin/eeprom diag-switch? true
/* Set the system to perform diagnostics on the next reboot. */
207.
/usr/sbin/eeprom local-mac-address?=true
/* Multiple Port Network Card Setting */
208.
/usr/sbin/grpck
/* Check /etc/group file syntax */
209.
/usr/sbin/pwck
/* Check /etc/passwd file syntax */
210.
/usr/sbin/sys-unconfig
/* Clear host specific network configuration information */
211.
/usr/sbin/useradd
/* Add a new user to the system */
212.
drvconfig ; disks
/* Adding hot-plug disks to system */



System Information/Monitoring
213. /bin/echo "0t${stamp}>Y\n<Y=Y" | adb
/* Convert UNIX timestamp to something human-readable */
214.
/usr/sbin/eeprom
/* Show eeprom parameters */
215.
/usr/sbin/prtconf -vp
/* Show system configuration details */
216.
coreadm -e log
/* Report global core */
217.
grep "\-root" /var/adm/sulog | grep -v \+ | tail -25
/* List most recent attempts to switch to superuser account. */
218.
isainfo -bv
/* Quickly checkout if machine is in 32 or 64 bit mode */
219.
last
/* Tells who was or still is on the system */
220.
logger -i
/* Log the process ID */
221.
prtconf -pv | grep banner-name |awk -F\' ' { print $2 } ' | head -1
/* Show actual model name of machine */
222.
prtdiag -v
/* System Diagnostics */
223.
prtpicl -v | grep wwn
/* A command to find persistent binding of storage */
224.
psradm -f [processor id]
/* Take processor offline */
225.
psrinfo | wc -l
/* Display number of processors */
226.
sar -u
/* Report CPU Utilization */
227.
sar [ -aA ] [ -o filename ] t [ n ]
/* Provides cumulative reports about system activity. */
228. telnet 13 | grep ':'
/* Get the time on remote Unix machine */
229.
uname -a
/* Displays system information */

230.
uname -X
/* Displays system information */
231. v
mstat 10
/* Displays summary of what the system is doing every 10 seconds */
232.
who -b
/* Displays the date of the last system reboot. */
233.
ypcat hosts | sort -n -t. +0 -1 +1 -2 +2 -3 +3 -4
/* Take the input of "ypcat hosts" or "cat /etc/inet/hosts" and sort by IP. */

World Clock